StephanieFleeting Epiphanies

realizations on life, the web, and everything

Random Sleep, Bad Temperature Sensors in 17" Powerbook

Posted Monday, January 23, 2006 2:18:11 PM by Stephanie

I have just spent the good part of two days trying to figure out why my 17" Powerbook (1.67GHz) has narcolepsy. And an annoying couple of days it has been. I've narrowed the problem down finally, but I still have not come up with a solution. I'm blogging here in hopes that someone has either A) seen the solution or B) can answer a couple questions I have that will lead me to it. C'mon Mac-heads, time to step up here! Imagine my surprise when I logged in to find the last post here was Tom Mucks' post on his dead Toshiba laptop. LOL I haven't had trouble with this one at all until this. And no, I don't have Apple Care and it's out of warranty.

Before someone hops into the comments and tells me to:

  • Repair permissions
  • Zap the PRAM
  • Reset the PMU
  • Repair permissions
  • Boot into single user and run fsck -fy
  • Repair permissions
  • Create a new user and test while running that
  • Check the console.log and system.log

Let me just save you the time and let you know that I've done all that ad nauseum... and none of it works for more than a little bit. However, in doing all that, I found that I do have the error in my system.log that states that the machine has overheated and is being put to sleep. The problem is, after installing Temperature Monitor, and keeping track for a couple days, I found that I don't have an overheating problem at all. What I have is an insanely whacked out Trackpad sensor -- or at least a whacked out reading -- caused by "I don't know what." And that's what I'm determined (hopefully with your help) to find out -- with as little down time as possible. A gurl has to work y'know! (The sensor readings can vary within a two second readout period from -193F to 243F. Likely these are incorrect since I'd either be freezing or burning at either temperature.)

I found two posts (actually more, but two that were somewhat helpful and confirmed my findings) outside the Apple forums. Why am I outside the Apple forums you ask? Well, for one, I found at least three threads there with the same problem -- but no solution. And also, because something is bad wrong with those forums right now and sometimes I have to click and time out five times before a page loads. Forget it. I done quit and gone ta googlin'...

In the first post I found at MacFixItForums, the guy was in Korea and ended up sending in his machine. Apple fixed it and according to him, the way they fixed it was, "Something about two contacts being pressed together under the surface to the left of the trackpad." OK... that's plausible. But I don't really want to take my machine apart to check for such unless that turns out to be the solution with none other.

In the second thread I found, a gentlemen that apparently works on Macs seems to have fixed it another way. He states he "repaired permissions using Terminal and discovered a library widget had the wrong permissions. Once the Widget permissions were fixed, the laptop immediately stopped going to sleep and had been fine ever since." This sounds much more like a solution I would like to try for myself. However, I've not figured out how to use the terminal to repair permissions. I know how to do it using Disk Utility only.

Does anyone have any clues for me? Has this triggered thoughts in your brain you might like to share? Here's hoping...

Category tags: Dreamweaver, Mac, This and That

See Community MX content by Stephanie